eFlite System Requirements

System Requirements

eFlite Desktop™ requires the .NET Framework 2.0 or newer and a PC running Windows 7 or newer operating system.

eFlite Mobile™ is designed for an iPad or iPhone with iOS 8 thru 13 operating system (iOS 14 not yet supported) and Android powered smartphones and tablets with version 4.4 or newer operating system.

eFlite Online™ is a web service requiring a browser (i.e. Chrome, Firefox, Edge or Safari) running on a desktop or laptop computer (any operating system), an Android powered phone or tablet or an iPhone or iPad with iOS 8 thru iOS 14 operating system.

Products & Services

Sales & Support

Latest News

Ramp checks are on the rise! Are you prepared? Learn More

NTSB: Improper Load & Center of Gravity Caused Challenger Crash Learn More

Maximize Useful Load with a Multiple Seating and Cargo Customization. Learn More

eFlite Integrates Supplemental Type Certificates FREE of Charge! Learn More

eFlite Software Meets AC 120-76C Electronic Flight Bag Guidelines. Learn More

eFlite Features Help Air Carriers Meet AC 120-27E Aircraft Weight and Balance Control Guidelines. Learn More

Minimize Flight Planning Calculations with a Multiple Seating and Cargo Customization. Learn More